System.NullReferenceException:

1
GerdMuellerSchramm
11/3/2014 2:27 PM

Hello,

When try to open the attached file with Sharp Viewer I get the following error message:

System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei .ƒ..„.“( config)
bei .ƒ.ˆ( config)
bei .ƒ.†(Œ context,  graphicsFactory)
bei .ƒ.œƒ(Œ context,  graphicsFactory)
bei ..ƒ(Œ context,  graphicsFactory)
bei ..ƒ(Œ context,  graphicsFactory)
bei .€.Žž( graphicsFactory,  graphicsConfig,  model, Matrix4D modelTransform)
bei .“.Žž( model, Matrix4D modelTransform)
bei .“.Žž( model)
bei “...ctor( model,  layout)
bei “...ctor(’ drawingInfo)
bei “.Ÿ.‰(’ drawingInfo)
bei “.Ÿ.’(String filename)
bei “.Ÿ.‘(Object sender, EventArgs eventArgs)
bei System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
bei System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
bei System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
bei System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.ToolStrip.WndProc(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Can somebody tell me what's wrong with the DXF file?

Thanks,
Gerd

rammi
11/10/2014 11:18 AM

Hi Gerd,

the DWG DXF Sharp Viewer is a bit lagging behind our current code where this exception is not thrown.
But an update for the viewer should appear later this month.

- Rammi

Wout
11/10/2014 6:32 PM

Hi,

We've released a new viewer version. The exception has been fixed, however there's still an issue with the display of this file, there's one hatch that CadLib is displaying that it shouldn't. So we still need to look into this further.

- Wout

Wout
11/11/2014 1:19 PM

The problem with the hatch has been fixed as well. CadLib ignored the FILLMODE, which was 0, when rendering the hatch.

Thank you for the report!

- Wout

1