Standard Edition Signing Trial

1
Brent Upton
3/10/2021 6:02 PM

Hello,

I was a CADLib user a few years ago (you might remember my name, perhaps not, i's been a few years) and I'm recently getting back in to doing some stuff with a new client where the library seems it could be of use. They've given me the go ahead to produce a proof of concept for this work and wanted to use the trial.

I attempted to download the .NET 4.0 installer, but I can't seem to (it just flashes instead of downloading the file), so I am attempting to create the snk file and sign my app and use the Standard edition. I've managed to create a trial from the public key but I cannot sign my application with the same keypair, as it expects a pfk and I can't seem to figure out how to create that from my snk.

I've never published or distributed my apps because they've never needed to be used by anyone other than me, and I'm a bit of a hack so I've never done this before.

I could use clickonce to generate a pfx and extract the public key from it, but since I've already started a trial with a different keypair, it won't let me start another one.

Please help a noob out here!

Brent Upton
3/10/2021 6:26 PM

OK, I've figured out how I can use the snk I created to sign, however when I add:

C# Code:
WW.WWLicense.SetLicense("MY LICENSE STRING");

In my code I get the error: A strongly-named assembly is required.

See attached image. The snk I'm using is the one I extracted the public key from to generate the trial license.

Wout
3/10/2021 6:34 PM

Hi Brent,

Yes I remember you ofcourse.

I just tried the download, seems to work ok in firefox.

You just sign the .NET assembly with the .snk file (in the signing tab, "Sign the assembly", not the "Sign the ClickOnce manifests", as it has nothing to do with ClickOnce).

- Wout

Wout
3/10/2021 6:48 PM

Also sign with the .snk file that has the key pair, not the one that has only the public key.

- Wout

Brent Upton
3/10/2021 6:49 PM

I just tried in an incognito window and it worked. I suspect some cookies or other nonsense got in the way.

If the 4.0 trial doesn't depend on the strong naming, I'll continue my testing with it, but just to show what I did to get where I got to:

used sn.exe to generate a keypair
exported the public key
used the public key to generate a trial license
installed WW.Cad.Standard from nuget in VS
added the WW.WWLicense.SetLicense line to the constructor of my form
tried to start it just to see if it worked

See attached for where I picked my snk and the error I'm getting.

1